Skip to content
言語: 日本語

AIアシスタント

その他のMCPクライアントを接続する

2026年11月1日更新 約5分で読めます

Cursor、MCP Inspectorなど他のMCPクライアント向けのサーバーURL、トランスポート、OAuthの流れと、開発者向けのすべてのディスカバリーアドレス。

ClaudeやChatGPT以外にも、HTTP経由のリモートサーバーとOAuthログインに対応したMCPクライアントであれば使えます。たとえばCursorのようなIDEや、テスト用のMCP Inspectorです。この記事は、そのようなクライアントを自分で設定する方や、独自の連携を作る方向けです。

主な仕様

サーバーURL
https://dock.at-harbor.com/mcp
トランスポート
Streamable HTTP、ステートレスです。各リクエストはJSON-RPCメッセージ(またはバッチ)を含むPOSTで、レスポンスはJSONで返ります。セッションIDやサーバーからのストリームはありません。
プロトコルバージョン
2025-11-25、2025-06-18、2025-03-26
メソッド
initialize、ping、tools/list、tools/callです。サーバーはresourcesやpromptsを提供していません。
ログイン
PKCE(S256)付きのOAuth 2.1です。トークンがない場合、サーバーは401を返し、WWW-Authenticateヘッダーでメタデータの場所を示します。

クライアントを設定する

  1. クライアントでリモートMCPサーバーを追加します(「Remote」「HTTP」「Streamable HTTP」などと呼ばれることが多いです)
  2. URLにhttps://dock.at-harbor.com/mcpを入力します
  3. クライアントIDとシークレットは空欄のままにします。クライアントが自分を登録します
  4. 接続を開始すると、ブラウザでログインが開き、その後LinkHarborの同意ページが表示されます
  5. ワークスペースと権限を選び、「許可」をクリックします

設定の名前はプログラムによって異なります。たとえばMCP Inspectorでは、「Streamable HTTP」トランスポートを選びます。

OAuthの流れの詳細

  1. クライアントがトークンなしでMCPサーバーを呼び出し、リソースメタデータへの参照付きで401を受け取ります
  2. 認可サーバーのメタデータ(エンドポイント、対応する方式、権限)を読み取ります
  3. Dynamic Client Registration、またはhttpsのURLにあるクライアントメタデータドキュメントで自分を登録します
  4. PKCEとresource=https://dock.at-harbor.com/mcpを含む認可リクエストでブラウザを開きます
  5. あなたがログインし、同意ページで判断します
  6. クライアントがコードをアクセストークンとリフレッシュトークンに交換します
ステップ有効期間
ログイン要求から判断まで10分
認可コード60秒、1回のみ使用可
アクセストークン1時間
リフレッシュトークン使用するたびに更新。90日間使われないと期限切れ

クライアントが権限を何も要求しない場合は、すべての権限が要求されます。同意ページで絞り込むこともできます。すでに置き換えられたリフレッシュトークンが再び使われた場合、LinkHarborはセキュリティ上の理由から接続全体を終了します。

リダイレクトアドレスのルール

  • httpsのアドレス
  • httpは自分のコンピューター上のループバックアドレスのみ(デスクトップクライアントとIDE向け)
  • 逆ドメイン表記の独自のアプリスキーム
  • クライアントごとに最大10個のアドレス、フラグメントは不可

アプリが自分用に登録されていないアドレスを送信した場合、LinkHarborは処理を停止します:「アプリが未登録の戻り先アドレスを送信しました。要求は停止されました。」

開発者向けのディスカバリーアドレス

ドキュメントアドレス
リソースメタデータ(RFC 9728)https://dock.at-harbor.com/.well-known/oauth-protected-resource/mcp
認可サーバー(RFC 8414)https://dock.at-harbor.com/.well-known/oauth-authorization-server
トークンの取り消し(RFC 7009)https://dock.at-harbor.com/oauth/revoke
MCP Server Cardhttps://dock.at-harbor.com/.well-known/mcp/server-card.json
エージェント向けの説明https://dock.at-harbor.com/auth.md

不明なアプリ

リダイレクトアドレスがすべてclaude.ai、claude.com、chatgpt.com、openai.comにあるアプリは既知のアプリとみなされます。localhost経由で戻る自分のコンピューター上のプログラム(Claude Code、Codex、IDEなど)では、同意ページに「LinkHarbor はこのアプリを把握していません。このアプリはお使いのコンピューター上で動作しています。ご自身で起動した直後の場合のみ続行してください。」という注記が表示され、下部には「選択後、お使いのコンピューター上のアプリに戻ります。」と表示されます。それ以外の未知のWebアプリでは「LinkHarbor はこのアプリを把握していません。ご自身で開始し、… を信頼できる場合のみ続行してください。」と表示され、… の部分にそのアドレスが入ります。クライアントを自分で設定した直後なら、どちらも正常です。ロゴは、アプリが送信した場合にのみ表示されます。自分でログインを開始していない場合は「拒否」をクリックしてください。

答えが見つかりませんか?

お困りのことをお知らせください。サポートチームが個別にお手伝いします。

サポートに問い合わせる